Задать вопрос
13 февраля, 18:31

Составьте программу генерирующую одномерный массив из элементов двумерного массива А (N, N), расположенных над главной диагональю

+3
Ответы (1)
  1. 13 февраля, 20:30
    0
    1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 const m = 100; var i, j, n: byte; arr1: array [1 ... m, 1 ... m] of integer; arr2: array [1 ... m] of integer; begin write ('Ко-во эл-ов квадратной матрицы: ') ; readln (n) ; for i:=1 to n do begin for j:=1 to n do begin arr1[i, j]:=random (50) ; write (arr1[i, j],' ') ; end; writeln; end; writeln ('Полученный массив:') ; for i:=1 to n do for j:=1 to n do if (j < n-i+1) then begin arr2[i]:=arr1[i, j]; write (arr2[i],' ') ; end; writeln; end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу генерирующую одномерный массив из элементов двумерного массива А (N, N), расположенных над главной диагональю ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы