Задать вопрос
29 сентября, 16:49

составьте программу, которая формирует массив, содержащий 16 случайных чисел, принадлежащих промежутку [-2; 3], и подсчитывает сумму отрицательных чисел. вывод в строку через запятую

+3
Ответы (1)
  1. 29 сентября, 20:03
    0
    Program Program1;

    var

    i, sum:integer;

    A: array [1 ... 16] of integer;

    begin

    randomize;

    for i:=1 to 16 do

    begin

    a[i]:=random (6) - 2;

    write (a[i],', ') ;

    end;

    sum:=0;

    for i:=1 to 16 do

    if a[i]<0 then sum:=sum+a[i];

    writeln ('Сумма отрицательных чисел равна', sum) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «составьте программу, которая формирует массив, содержащий 16 случайных чисел, принадлежащих промежутку [-2; 3], и подсчитывает сумму ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы