Задать вопрос
3 октября, 20:27

Напишите программу в паскале, которая вводит два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными.

+1
Ответы (1)
  1. 3 октября, 21:39
    0
    Var x, y, p, i:integer;

    begin

    readln (x, y) ;

    for i:=1 to abs (y) do p:=p+x;

    if y<0 then p:=-p;

    writeln (p) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу в паскале, которая вводит два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы