Задать вопрос
2 февраля, 02:58

составить программу вывода N случайных целых чисел диапазона от 0 до 50. определить сколько среди них четных, а сколько нечетных

+1
Ответы (1)
  1. 2 февраля, 04:24
    0
    Program gt;

    var a, l, k, n, i:integer;

    begin

    read (N) ;

    randomize;

    k:=0;

    l:=0;

    for i:=1 to n do

    begin

    a:=random (50) ;

    if (a mod 2=0) then k:=k+1 else l:=l+1;

    write (a,' ') ;

    end;

    writeln;

    writeln ('четные=', k) ;

    writeln ('не четные=', l) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «составить программу вывода N случайных целых чисел диапазона от 0 до 50. определить сколько среди них четных, а сколько нечетных ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы