Задать вопрос
6 октября, 13:57

Составьте программу для вычисления суммы цифр введенного с клавиатуры трехзначного натурального числа.

+1
Ответы (1)
  1. 6 октября, 17:22
    0
    Program z1;

    var

    a: integer;

    c: byte;

    begin

    readln (a) ;

    c:=0;

    while a 0 do begin

    c:=c + a mod 10;

    a:=a div 10;

    end;

    writeln ('Summa: ', c) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу для вычисления суммы цифр введенного с клавиатуры трехзначного натурального числа. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы