Задать вопрос
17 октября, 12:25

1. С клавиатуры вводится слово, распечатать все его буквы через пробел. (после последней буквы пробела быть не должно).

2. Написать программу, которая удаляет первое слово из строки введенной с клавиатуры и вместо него вставляет заданное.

+5
Ответы (1)
  1. 17 октября, 16:04
    0
    1)

    var

    a:string;

    i, n:integer;

    begin

    readln (a) ;

    n:=length (a) ;

    for i:=1 to n do

    write (' ', a[i]) ;

    end.

    2)

    var

    a, b:string;

    i, n, d:integer;

    begin

    Writeln ('введите строку') ;

    readln (a) ;

    n:=length (a) ;

    d:=pos (' ', a) ;

    Delete (a, 1, d-1) ;

    writeln ('введите слово для замены') ;

    readln (b) ;

    Insert (b, a, 1) ;

    writeln;

    writeln (a) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1. С клавиатуры вводится слово, распечатать все его буквы через пробел. (после последней буквы пробела быть не должно). 2. Написать ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы