Задать вопрос
16 мая, 08:03

Составить программу в Паскаль: Дано число меньше 16 определить - сколько единичных битов содержит двоичная запись этого числа.

+4
Ответы (1)
  1. 16 мая, 11:05
    0
    Var b, a, c, kol:integer;

    begin

    writeln ('введите число в десятичной системе счисления') ;

    readln (a) ;

    kol:=0;

    while (a>=2) do begin

    c:=a div 2;

    b:=2*c;

    b:=a-b;

    writeln (b) ;

    a:=c;

    if a<2 then

    writeln (a) ;

    if a > 0 then

    kol:=kol+1;

    end;

    writeln ('количество 'kol) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу в Паскаль: Дано число меньше 16 определить - сколько единичных битов содержит двоичная запись этого числа. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы