Задать вопрос
6 октября, 04:32

Решить в целых числах уравнение (ax - b) / (cx - d) = 0.

Входные данные

Вводятся 4 числа: a, b, c и d

Выходные данные

Вывести значения корней и их количество, вывести фразу "Нет корней" при их отсутствии и вывести фразу "solution" если корней бесконечно много.

Программа на Pascal

+1
Ответы (1)
  1. 6 октября, 07:01
    0
    program n5;

    uses crt;

    var a, b, c, d, x:integer;

    begin

    read (a, b, c, d) ;

    if (b=0) and (a0) then write ('solution') ;

    if (b0) and (a=0) then write ('нет корней') ;

    if (b0) and (a0) and (b mod a=0) then write (-b div a) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Решить в целых числах уравнение (ax - b) / (cx - d) = 0. Входные данные Вводятся 4 числа: a, b, c и d Выходные данные Вывести значения ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы