Задать вопрос
17 августа, 10:45

Написать программу на языке Pascal (цикл for и while). Найти сумму нечетных чисел в промежутке от 20 до n

+3
Ответы (2)
  1. 17 августа, 11:20
    0
    Program l;

    var

    i, n, s: integer;

    begin

    writeln ('Введите n') ;

    readln (n) ;

    for i = 20 to n do begin

    if (i mod 2 0) then

    s : = s + i;

    end;

    write (s) ;

    end.
  2. 17 августа, 12:52
    0
    Var

    i, n, s:integer;

    begin

    Write ('n=') ;

    Readln (n) ;

    s:=0;

    for i:=20 to n do

    if Odd (i) then s:=s+i;

    Writeln ('Сумма с for = ', s) ;

    s:=0; i:=21;

    while i<=n do

    begin

    s:=s+i;

    i:=i+2

    end;

    Writeln ('Сумма с while = ', s)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу на языке Pascal (цикл for и while). Найти сумму нечетных чисел в промежутке от 20 до n ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы