Задать вопрос
19 июля, 17:31

На языке программирования Pascal составить программу, которая проверяет, является ли введенное с клавиатуры число простым или нет (т. е. число делится только на 1 и на само себя без остатка) (число 354)

+5
Ответы (1)
  1. 19 июля, 19:21
    0
    function isPrime (n:integer) : boolean;

    var res:boolean;

    i:integer;

    begin

    if n>1 then res:=true

    else res:=false;

    for i:=2 to n div 2 do

    if n mod i = 0 then

    begin

    res:=false;

    break;

    end;

    isPrime:=res;

    end;

    var n:integer;

    begin

    writeln ('введите целое число: n = ') ;

    readln (n) ;

    write (isPrime (n)) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «На языке программирования Pascal составить программу, которая проверяет, является ли введенное с клавиатуры число простым или нет (т. е. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы