Задать вопрос
24 января, 12:00

Clrscr; ДАЮ 30 Б

Составить программу на языке Паскаль, возведения числа х в степень числа y.

+4
Ответы (1)
  1. 24 января, 15:43
    0
    var

    x, y, result:real;

    begin

    readln (x, y) ;

    result : = 1;

    if y > 0 then

    begin

    while y 0 do

    begin

    result : = result * x;

    y : = y - 1;

    end;

    end

    else if y < 0 then

    begin

    while y 0 do

    begin

    result : = result * x;

    y : = y + 1;

    end;

    result : = 1 / result;

    end

    else result : = 1;

    writeln ('x^y = ', result) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Clrscr; ДАЮ 30 Б Составить программу на языке Паскаль, возведения числа х в степень числа y. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы