Задать вопрос
22 декабря, 03:07

Составьте программу, которая формирует массив из 12 случайных целых чисел, принадлежащих промежутку [-40; 40], и вычесляет сумму положительных чисел

+5
Ответы (1)
  1. 22 декабря, 03:54
    0
    a:array[1 ... 12] of integer;

    var

    k:integer;

    begin

    k:=0;

    for i:=1 to 12 do begin

    a[i]:=random (100) - 40;

    writeln (a[i]) ;

    end;

    for i:=1 to 12 do

    if a[i]>0 then k:=k+a[i];

    writeln (k) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу, которая формирует массив из 12 случайных целых чисел, принадлежащих промежутку [-40; 40], и вычесляет сумму ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы