Задать вопрос
31 мая, 22:55

Написать программу решения следующей задачи: Определить периметры

трѐх треугольников, если заданы координаты их вершин. Использовать

подпрограмму-функцию

+4
Ответы (1)
  1. 31 мая, 23:00
    0
    1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 uses crt; var i, xa, ya, xb, yb, xc, yc: integer; function Dlina (x1, y1, x2, y2: integer) : real; var d: real; begin d: = sqrt (sqr (y1-y2) + sqr (x1-x2)) ; Dlina:=d; end; function Perimetr (a, b, c: real) : real; begin Perimetr:=a+b+c; end; procedure Vvod (nt: byte; var ax, ay, bx, by, cx, cy: integer) ; begin writeln ('Координаты вершины A ', nt,' треугольника') ; readln (ax, ay) ; writeln ('Координаты вершины B ', nt,' треугольника') ; readln (bx, by) ; writeln ('Координаты вершины C ', nt,' треугольника') ; readln (cx, cy) ; end; begin for i:=1 to 3 do begin Vvod (i, xa, ya, xb, yb, xc, yc) ; writeln ('Периметр ', i,' треугольника = ', Perimetr (Dlina (xa, ya, xb, yb), Dlina (xb, yb, xc, yc), Dlina (xc, yc, xa, ya)) : 0:2) ; writeln; end; readkey end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу решения следующей задачи: Определить периметры трѐх треугольников, если заданы координаты их вершин. Использовать ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Используя подпрограмму-функцию написать алгоритм решения задачи: Написать функцию, которая находит сумму цифр целого числа.
Ответы (1)
Нужно сделать подпрограмму. Помогите не умею я подпрограммы писать! 9 класс, Делфи Сделать подпрограмму, которая вводит с клавиатуры 3 числа, находит найбольшее и выводит на экран.
Ответы (1)
Разработать подпрограмму, которая в качестве аргумента получает целое число и проверяет, является ли оно простым. Используя подпрограмму вывести на экран все простые числа из промежутка целых чисел, определенного пользователем. Pascal ABC
Ответы (1)
Прямоугольник. Зная координаты трех вершин прямоугольника на координатной плоскости, определить координаты четвертой вершины. Входные данные В одной строке записаны шесть чисел - координаты трех вершин прямоугольника.
Ответы (1)
Написать программу табулирования функции, заданной выражением: Y = х2 + 4x + 3, когда x изменяется от - 2 до 2 с шагом 0.2. Использовать для вычислений подпрограмму-функцию. 1. Текст программы.
Нет ответа