Задать вопрос
1 января, 15:09

Написать программу, которая подсчитывает количество положительных и отрицательных элементов файла целых чисел des. dat. Pascal ABC

+5
Ответы (1)
  1. 1 января, 17:22
    0
    Var

    f:file of integer;

    i, n, kp, ko:integer;

    begin

    { создать файл }

    randomize;

    assign (f,'des. dat') ;

    rewrite (f) ;

    for i:=1 to 20 do

    begin

    n:=random (101) - 50;

    Write (n,' ') ;

    Write (f, n)

    end;

    close (f) ;

    Writeln;

    { работа с файлом }

    ko:=0;

    kp:=0;

    reset (f) ;

    while not eof (f) do

    begin

    Read (f, n) ;

    if n>0 then Inc (kp)

    else if n<0 then Inc (ko)

    end;

    close (f) ;

    Writeln ('Положительных ', kp,', отрицательных ', ko)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая подсчитывает количество положительных и отрицательных элементов файла целых чисел des. dat. Pascal ABC ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы