Задать вопрос
7 августа, 13:56

Написать программу, которая выводит пример на умножение двух однозначных чисел, которые выбираются случайным образом, запрашивает ответ пользователя, проверяет его и выводит сообщение "Правильно!" или "Вы ошиблись" и верный результат. Pascal ABC

+1
Ответы (1)
  1. 7 августа, 15:27
    0
    Var

    a, b, r:byte;

    begin

    randomize;

    a:=Random (9) + 1;

    b:=Random (9) + 1;

    Write (a,' x ', b,' = ') ;

    Readln (r) ;

    if r=a*b then Writeln ('Правильно!')

    else Writeln ('Вы ошиблись. Верный результат ', a*b)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая выводит пример на умножение двух однозначных чисел, которые выбираются случайным образом, запрашивает ответ ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы