Задать вопрос
31 января, 22:01

Написать программу, которая запрашивает слово и проверяет, является ли это слово палиндромом. Pascal ABC

+5
Ответы (2)
  1. 31 января, 23:08
    0
    Var

    s:string;

    i, n:byte;

    p:boolean;

    begin

    Write ('Введите слово: ') ;

    Readln (s) ;

    n:=Length (s) ;

    p:=true;

    for i:=1 to n div 2 do

    if s[i]s[n-i+1] then

    begin

    p:=false;

    break

    end;

    if p then Writeln ('Палиндром')

    else Writeln ('Не палиндром')

    end.
  2. 1 февраля, 00:02
    0
    var

    s: string;

    function Invert (s: string) : string;

    var

    i: integer;

    t: string;

    begin

    t : = '';

    for i : = 1 to length (s) do

    t : = s[i] + t;

    Invert : = t;

    end;

    begin

    Write ('Введите слово: ') ;

    Readln (s) ;

    s : = Trim (s) ;

    s : = Uppercase (s) ;

    if Invert (s) = s then

    Writeln ('Палиндром')

    else

    Writeln ('Не палиндром') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая запрашивает слово и проверяет, является ли это слово палиндромом. Pascal ABC ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы