Задать вопрос
23 мая, 11:56

Сделать небольшую программу в паскале

В параде принимают участие M военных. Командование парада решило, что наиболее

эффектное построение военных - в форме квадрата, то есть число участников построения

должно быть точным квадратом. Но поскольку число M может не быть точным квадратом,

разрешается разбить военных на несколько полков, каждый из которых строится в форме

квадрата. Для красоты все полки должны быть одинакового размера, также командование

парада хочет, чтобы размер каждого полка был как можно больше. Определите максимально

возможный размер полка.

Программа получает на вход одно целое положительное число M,

не превосходящее 2*109

, - количество участников парад. Программа должна вывести одно

число - максимально возможный размер полка.

Пример входных и выходных данных

Ввод Вывод

180 36

+5
Ответы (1)
  1. 23 мая, 14:41
    0
    var m, k: integer;

    begin

    readln (m) ;

    k:=round (sqrt (m)) ;

    while m mod sqr (k) 0 do k:=k-1;

    writeln (k*k) ;

    end.

    Пример:

    180

    36
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Сделать небольшую программу в паскале В параде принимают участие M военных. Командование парада решило, что наиболее эффектное построение ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы