Задать вопрос
9 сентября, 08:06

Решите задачу на одномерный массив.

Определите количество 0 в заданном массиве.

+3
Ответы (1)
  1. 9 сентября, 10:24
    0
    var a:array[1 ... 100000] of integer;

    i, n, k:integer;

    begin

    k:=0;

    readln (n) ;

    for i:=1 to n do begin readln (a[i]) ; if (a[i]=0) then k:=k+1; end;

    writeln (k) ;

    end.

    {Сначала вводится количество чисел в массиве (n), после этого вводится каждое число (a[i]) и если оно равно 0, то переменная k (количество)

    увеличивается на 1}
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Решите задачу на одномерный массив. Определите количество 0 в заданном массиве. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы