Задать вопрос
16 февраля, 19:56

Имя входного файла: стандартный ввод

Имя выходного файла: стандартный вывод

Ограничение по времени: 1 секунда

Ограничение по памяти: 256 мегабайт

У Жарасхана есть массив а из n чисел, к каждому числу массива Жарасхан должен применять лишь одну операцию. есть три операции.

1 добавить к числу один

2 отнять от числа один

3 добавить к числу ноль

к каждому элементу массива нужно применить одну из трех операции так, чтоб после применения операции ко всем элементам массива, количество одинаковых чисел в массиве стало максимальным.

Формат входных данных

В первой строке входных данных дано одно целое число N-размер массива. Во второй строке входных данных даны элементы массива а.

Формат выходных данных

Выведите одно целое число-максимальное количество одинаковых чисел в массиве после применения операций.

Система оценки

Данная задача имеет 4 подзадачи:

1. 1 2. 1 3. 1 4. 1

+3
Ответы (1)
  1. 16 февраля, 23:50
    0
    Program b;

    var a: array [1 ... 10000] of real;

    x: real;

    n, i, j, k, m, max: integer;

    begin

    read (n) ;

    for i: = 1 to n do read ([i]) ;

    max:=0;

    for i:=1 to n do

    for k:=-1 to 1 do

    begin x:=a[i]+k;

    m:=0;

    for j:=1+0 n do

    if (a[j]-1=x) or (a[j]+0=x) or (a[j]+1=x) then m:m+1;

    if m>max then max:=m;

    end;

    write (max) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Имя входного файла: стандартный ввод Имя выходного файла: стандартный вывод Ограничение по времени: 1 секунда Ограничение по памяти: 256 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы