Задать вопрос
19 октября, 10:24

Напишите программу которая в последовательности натуральных 20 чисел определяет сумму чисел кратных 6

На языке Паскаль

+3
Ответы (1)
  1. 19 октября, 13:39
    0
    1) Решение с массивами

    var

    a: array[1 ... 20] of longint;

    i, sum: longint;

    begin

    for i:=1 to 20 do

    begin

    read (a[i]) ;

    if a[i] mod 6=0 then sum:=sum+a[i];

    end;

    writeln (sum) ;

    end.

    Постановка задачи позволяет отказаться от использования массивов и работать только с тремя целочисленными переменными.

    2) Решение без массивов

    var

    x, i, sum: longint;

    begin

    for i:=1 to 20 do

    begin

    read (x) ;

    if x mod 6=0 then sum:=sum+x;

    end;

    writeln (sum) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу которая в последовательности натуральных 20 чисел определяет сумму чисел кратных 6 На языке Паскаль ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы