Задать вопрос
8 января, 02:12

Написать программу, которая запрашивает коэффициенты квадратного уравнения и сообщает, сколько корней имеет уравнение. Pascal ABC

+2
Ответы (1)
  1. 8 января, 04:35
    0
    Var

    a, b, c, d:real;

    begin

    Write ('Введите коэффициенты уравнения a, b, c: ') ;

    Readln (a, b, c) ;

    d:=b*b-4*a*c;

    if d<0 then Writeln ('Корней нет')

    else if d=0 then Writeln ('Один корень')

    else Writeln ('Два корня')

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая запрашивает коэффициенты квадратного уравнения и сообщает, сколько корней имеет уравнение. Pascal ABC ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы