Задать вопрос
20 января, 06:36

Написать программу вычисления суммы целых чисел от 1 до n, запрашиваемого с клавиатуры. Pascal ABC

+3
Ответы (2)
  1. 20 января, 08:27
    0
    Var

    s, n:integer;

    begin

    Write ('Введите n:') ;

    Readln (n) ;

    s:=n + (n * (n-1)) div 2; { сумма арифметической прогрессии }

    Writeln ('Сумма чисел от 1 до ', n,' равна ', s)

    end.
  2. 20 января, 09:59
    0
    Var

    i, n: integer;

    sum: longint;

    begin

    write ('n = ') ;

    readln (n) ;

    for i : = 1 to n do sum : = sum + i;

    writeln ('Сумма чисел от 1 до ', n, ' = ', sum) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу вычисления суммы целых чисел от 1 до n, запрашиваемого с клавиатуры. Pascal ABC ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы