Задать вопрос
1 мая, 10:24

Написать программу, которая вычисляет, сколько раз введенное с клавиатуры число встречается в линейном массиве из 10 случайных чисел. Pascal ABC

+5
Ответы (1)
  1. 1 мая, 13:17
    0
    Var

    a:array[1 ... 10] of integer;

    b, i, k:integer;

    begin

    Randomize;

    Write ('Введите количество элементов в массиве: ') ;

    for i:=1 to 10 do

    begin

    a[i]:=Random (21) - 10;

    Write (a[i],' ')

    end;

    Writeln;

    Write ('Какое число искать? ') ;

    Readln (b) ;

    k:=0;

    for i:=1 to 10 do

    if a[i]=b then Inc (k) ;

    Writeln ('Число встречается ', k,' раз')

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая вычисляет, сколько раз введенное с клавиатуры число встречается в линейном массиве из 10 случайных чисел. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы