Задать вопрос
1 января, 11:49

Написать программу для решения задачи: Сравнить первую и последнюю цифру натурального четырёхзначного числа n. На экране должен появиться запрос на ввод числа и результат решения задачи, например 1) вводится число 1475, выводится "первая цифра меньше последней: 12". 3) вводится число 7457, выводится "первая цифра равна последней: 7=7"

+3
Ответы (1)
  1. 1 января, 14:01
    0
    var n:integer;

    begin

    write ('Введите 4-х значное число: ') ;

    readln (n) ;

    if n div 1000 = n mod 10 then write ('Первая цифра равна последней: ', n div 1000,'=', n mod 10)

    else if n div 1000 > n mod 10 then write ('Первая цифра больше последней: ', n div 1000,'>', n mod 10)

    else write ('Первая цифра меньше последней: ', n div 1000,'<', n mod 10)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу для решения задачи: Сравнить первую и последнюю цифру натурального четырёхзначного числа n. На экране должен появиться ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы