Задать вопрос
19 мая, 19:45

Необходимо решить следующую предметную задачу и написать программу на языке Паскаль. Для любого целого k обозначим количество цифр в его десятичной записи Ц (k).

Например: Ц (1) = 1, Ц (9) = 1, Ц (10) = 2. Дано натуральное число n. Вычислить:

(Ц (1) / 1) + (Ц (2) / 2^2) + ... + (Ц (n) / n^2)

+3
Ответы (1)
  1. 19 мая, 21:41
    0
    program crash;

    var n, k: integer;

    r: real;

    begin

    write ('n = ') ;

    readln (n) ;

    k : = 0;

    r : = 0;

    while n > 0 do

    begin

    k : = k + 1;

    r : = r + (n mod 10) / (k * k) ;

    n : = n div 10

    end;

    writeln ('r = ', r:0:14) ;

    readln

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Необходимо решить следующую предметную задачу и написать программу на языке Паскаль. Для любого целого k обозначим количество цифр в его ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы