Задать вопрос
24 октября, 19:56

С клавиатуры вводятся произвольные числа необходимо вычислить разность всех введенных чисел условием выхода из цикла является произведение чисел больше 1000

Написать программу на языке паскаль

+5
Ответы (1)
  1. 24 октября, 20:22
    0
    Если я правильно понял задание, то вот:

    var d, p, n:Real;

    begin

    d : = 0; p: = 1;

    while (p < = 1000) do begin

    read (n) ;

    if (n >0) then d : = d-n;

    p : = p*n;

    end

    writeln () ;

    writeln ('Разность: ', d) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «С клавиатуры вводятся произвольные числа необходимо вычислить разность всех введенных чисел условием выхода из цикла является произведение ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы