Задать вопрос
18 августа, 18:38

Ввести двузначное целое число х<15. Написать программу перевода его в восьмеричную систему счисления. (Паскаль)

+3
Ответы (1)
  1. 18 августа, 22:25
    0
    Const zs='01234567'; / / цифры в 8 СС

    s:string;

    begin

    write ('Введите число в 10 СС: ') ;

    readln (n) ;

    s:='';

    while n>0 do

    begin

    s:=zs[n mod 8+1]+s; / / берем остаток от деления на 8 и эту цифру пишем в начало строки

    n:=n div 8 / / сокращаем число

    end;

    write ('Число в 8 СС: ', s) ;

    readln

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Ввести двузначное целое число х ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы