Задать вопрос
31 декабря, 02:57

Дружественные числа - это два натуральных числа, таких, что сумма всех делителей одного числа (меньших самого этого числа) равна другому числу, и наоборот. Напишите программу, которая будет искать дружеские пары чисел до 100 000. Pascal

+2
Ответы (1)
  1. 31 декабря, 05:50
    0
    Function sum_del (x: longint) : longint;

    var

    s, i: longint;

    begin

    s : = 0;

    for i : = 1 to x div 2 do

    if x mod i = 0 then

    s : = s + i;

    sum_del : = s;

    end;

    var

    i, s1, s2: longint;

    begin

    for i : = 1 to 100000 do

    begin

    s1 : = sum_del (i) ;

    s2 : = sum_del (s1) ;

    if (s2 = i) and (s1 < i) then

    writeln (s1, ' ', i) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дружественные числа - это два натуральных числа, таких, что сумма всех делителей одного числа (меньших самого этого числа) равна другому ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы