Задать вопрос
28 января, 21:40

Написать задачу на языке PascalABC

По одну сторону улицы находятся дома с нечетными номерами (1,3,5, ...),

по другую сторону - четными (2,4,6, ...). Дом 1 находится напротив дома 2, дом 3 - напротив дома 4 и тд. До соседнего дома нужно идти вдоль по улице одну минуту, неважно, с какой стороны улицы он находится (то есть от дома 1 нужно идти одну минуту как до дома 3, так и до дома 4). До дома, стоящего напротив, идти не нужно.

Человек вышел на улицу из дома А и должен дойти до дома В. Определите, сколько минут ему нужно идти вдоль по улице.

Программа получает на вход два различных целых положительных числа А и В, не превосходящие 2•10 (в 9 степени), - номера домов. Программа должна вывести одно число-искомое количестао минут.

Пример входных и выходных данных:

Ввод: 1, 8

Вывод: 3

+1
Ответы (1)
  1. 28 января, 23:24
    0
    begin

    var a:=ReadInteger;

    var b:=ReadInteger;

    var min:=0.0;

    for var i:=a to b do

    begin

    min+=0.5;

    end;

    If odd (a) and not odd (b) then

    write (min-1) ;

    If not odd (a) and odd (b) then

    write (min) ;

    If (not odd (a) and not odd (b)) or (odd (a) and odd (b)) then

    write (min-0.5) ;

    end.

    Вроде так, но не уверен!
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать задачу на языке PascalABC По одну сторону улицы находятся дома с нечетными номерами (1,3,5, ...), по другую сторону - четными ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы