Задать вопрос
5 декабря, 10:41

Решать в Pascal

Найти наибольший элемент заданной целочисленной числовой последовательности.

Входные данные: Во входном потоке в первой строке задано натуральное число N (N < = 1000) - количество элементов числовой последовательности. Во второй строке через пробел перечислены значения элементов последовательности Ai (-32000 < = Ai < = 32000).

Выходные данные: В выходной поток вывести единственное целое число.

Пример входного файла (input. txt) : 8

100 10 - 10 - 100 300 32000 20000 - 30000

Пример выходного файла (output. txt) : 32000

Мое решение (ошибку скажите) :

var a, b, max, i:longint;

begin

read (a) ;

for i:=1 to a do begin

read (b) ;

if b>=max then max:=b;

end;

write (max) ;

end.

+1
Ответы (1)
  1. 5 декабря, 11:27
    0
    Ошибка заключается в том, что переменную max нужно инициализировать прежде, чем будет осуществлен вход в цикл.

    var a, b, max, i : longint;

    begin

    read (a) ;

    max : = - 32001;

    for i:=1 to a do begin

    read (b) ;

    if b > = max then

    max:=b;

    end;

    write (max) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Решать в Pascal Найти наибольший элемент заданной целочисленной числовой последовательности. Входные данные: Во входном потоке в первой ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы