Задать вопрос
8 июля, 11:00

Решить задачу с помощью цикла с предусловием 1) Организовать проверку пароля, если пароль верный - написать "Вход в систему разрешен", если пароль не угадан 5 раз - прекратить проверку пароля. 2) Ввести целое число и найти сумму его цифр. Пример: Введите целое число: 1234 Сумма цифр числа 1234 равна 10.

9 класс через pascal прошу!

+2
Ответы (2)
  1. 8 июля, 11:28
    0
    1) Пароль в этом коде - "zn4n1j4". Заменить при необходимости.

    var

    i: integer;

    s: string;

    begin

    i : = 1;

    while i < = 5 do

    begin

    readln (s) ;

    if s = 'zn4n1j4' then

    begin

    writeln ('Вход в систему разрешен') ;

    exit;

    end;

    writeln ('Неверный пароль.') ;

    end;

    writeln ('Пароль не был угадан 5 раз.') ;

    end.

    2) Используем операцию x mod 10 для получения последней цифры числа и x div 10 для "отбрасывания" последней цифры числа.

    var

    x, ans: integer;

    begin

    read (x) ;

    ans : = 0;

    while x 0 do

    begin

    ans : = ans + (x mod 10) ;

    x : = x div 10;

    end;

    writeln (ans) ;

    end.
  2. 8 июля, 12:38
    0
    1.

    var k:integer;

    p, p1:string;

    begin

    k:=5;

    write ('Введите пароль: ') ;

    readln (p) ;

    while k>=1 do

    begin

    write ('Подтвердите пароль: ') ;

    readln (p1) ;

    if p=p1 then

    begin

    writeln ('Вход в систему разрешен') ;

    k:=0

    end

    else

    k:=k-1

    end

    end.

    2.

    var a, s:integer;

    begin

    write ('Введите число: ') ;

    readln (a) ;

    while a>0 do

    begin

    s:=s+a mod 10;

    a:=a div 10

    end;

    write ('Сумма цифр: ', s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Решить задачу с помощью цикла с предусловием 1) Организовать проверку пароля, если пароль верный - написать "Вход в систему разрешен", если ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
1. Ввести целое число и найти сумму его цифр. Пример Введите целое число 1234 Сумма цифр числа 1234 равна 10 2. Вычислить в Паскале степень числа, используя цикл while
Ответы (1)
Пароль Игорь придумал пароль из 16 символов, состоящий из цифр и английских букв. Чтобы его не забыть, он решил записать пароль, но предварительно хочет его зашифровать.
Ответы (1)
Ввести целое число и определить, верно ли, что в нём ровно 3 цифры. Нужно с помощью цикла "while" Пример: Введите число: 123 Да Пример: Введите число: 1234 Нет.
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)
Игорь придумал пароль из 16 символов, состоящий из цифр и английских букв. Чтобы его не забыть, он решил записать пароль, но предварительно хочет его зашифровать.
Ответы (2)