Задать вопрос
29 августа, 02:00

Программисты, помогите! нужно написать программу на паскале дано натуральное число n. Найти произведение нечетных чисел от 1 до n. C Longint и integer.

+3
Ответы (1)
  1. 29 августа, 04:04
    0
    Var

    n, i: integer;

    pr: longint;

    begin

    readln (n) ;

    pr : = 1;

    i : = 1;

    while (i < = n) do begin

    i : = i + 2;

    pr : = pr * i;

    end;

    pr : = pr div i;

    writeln (pr) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Программисты, помогите! нужно написать программу на паскале дано натуральное число n. Найти произведение нечетных чисел от 1 до n. C ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы