Задать вопрос
25 августа, 02:09

Напишите программу, которая выводит символы с кодами от N до М (в три столбца)

Напишите фрагмент задачи, в котором будет определяться символ по своему коду

Напишите фрагмент задачи, в которой будет определяться код символа

+2
Ответы (1)
  1. 25 августа, 03:12
    0
    var n, m, i, k:integer; c:char;

    begin

    / / 1

    write ('n, m: ') ;

    readln (n, m) ;

    k:=0;

    for i:=n to m do

    begin

    write (i,' - ', chr (i),' ') ;

    k:=k+1;

    if k mod 3=0 then writeln;

    end;

    / / 2

    write ('n: ') ;

    readln (n) ;

    writeln (n,' ', chr (n)) ;

    / / 3

    write ('c: ') ;

    readln (c) ;

    writeln (c,' ', ord (c)) ;

    end.

    Пример:

    n, m: 40 60

    40 - (41 -) 42 - *

    43 - + 44 -, 45 - -

    46 -. 47 - / 48 - 0

    49 - 1 50 - 2 51 - 3

    52 - 4 53 - 5 54 - 6

    55 - 7 56 - 8 57 - 9

    58 - : 59 -; 60 - <

    n: 100

    100 d

    c: {

    { 123
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая выводит символы с кодами от N до М (в три столбца) Напишите фрагмент задачи, в котором будет определяться ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы