Задать вопрос
29 апреля, 21:26

Котик загадывает случайное число от 1 до 10. Это число записано в переменной.

Котик тебя спрашивает: Какое число я загадал?

А затем сравнивает твой ответ с числом, которое загадал.

Если твой ответ равен числу, то ты выиграл.

Если число больше ответа, то котик говорит: "Мое число больше!"

Если число меньше ответа, то котик говорит: "Мое число меньше!"

Всего дается 3 попытки, чтобы угадать число!

Для этого используй еще одну переменную попытки.

Попытки уменьшаются, когда ты ввел неправильное число.

+1
Ответы (1)
  1. 29 апреля, 23:01
    0
    var a, b, k:integer;

    begin

    b:=random (10) + 1;

    WriteLn ('Какое число я загадал?') ;

    k:=3;

    repeat

    Write ('У тебя ', k,' попытки (-а). Введи число: ') ;

    ReadLn (a) ;

    if a>b then WriteLn ('Мое число меньше!') else

    if a
    if a=b then

    begin

    WriteLn ('Молодец! Угадал!') ;

    k:=0;

    end;

    k:=k-1

    until k<=0;

    if k=0 then WriteLn ('Проиграл!') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Котик загадывает случайное число от 1 до 10. Это число записано в переменной. Котик тебя спрашивает: Какое число я загадал? А затем ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Паскаль программа 1) Программа загадывает случайное целое число из отрезка [1; 10] и просит пользователя его угадать, вводя варианты с клавиатуры, пока пользователь не угадает число, программа будет ему подсказывать, сообщая больше или меньше число
Ответы (1)
Составьте программу (в Pascal) "Угадай". Программа задумывает случайное число в диапазоне от 0 до 99. Программа задумывает случайное число в диапазоне от 0 до 99. После каждой попытки играющего прога выводит сообщение "больше", "меньше", "угадано".
Ответы (1)
Некоторый язык программирования допускает хранить в переменной целые неотрицательные числа размером не больше 2 байт, если же попробовать сохранить число в переменную этого языка размером больше 2 байт, тогда в переменную сохранятся только 2 старших
Ответы (1)
Запишите на алгоритмическом языке алгоритм, в результате которого переменной A будет присвоено значение переменной B, переменной B-значение переменной C, а переменной C-значение переменной A. Используйте не более одной промежуточной переменной.
Ответы (1)
В англо-русском словарике 80 страниц, на каждой из который по 50 слов. Петя открыл словарь на случайной странице и загадал случайное слово с этой страницы. Сможет ли Витя угадать его за 12 вопросов? Петя отвечает на вопросы только "да" или "нет".
Ответы (1)