Задать вопрос
1 июня, 16:09

Напишите программу, которая для введенной десятичной дроби выполняет сдвиг десятичной точки на указанное число разрядов (позиций) вправо (если количество разрядов задано положительное) или влево (если количество разрядов задано отрицательное). язык Pascal

+5
Ответы (1)
  1. 1 июня, 19:03
    0
    Var r, i:integer;

    a:real;

    begin

    write ('Введите число: ') ;

    readln (a) ;

    write ('Введите число разрядов (позиций) : ') ;

    readln (r) ;

    if (r>0) then for i:=1 to r do a:=a*10;

    if (r<0) then for i:=1 to abs (r) do a:=a/10;

    writeln (a)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая для введенной десятичной дроби выполняет сдвиг десятичной точки на указанное число разрядов (позиций) вправо ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы