Задать вопрос
2 февраля, 23:42

Помогите:

Практическая работа №3. Ветвления

Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них.

Пример:

Введите два числа: 1 5

Наименьшее число 1

Наибольшее число 5

Уровень B. Напишите программу, которая получает с клавиатуры четыре целых числа и находит наибольшее из них.

Пример:

Введите четыре числа: 1 2 5 3

Наибольшее число 5

Уровень C. Напишите программу, которая получает с клавиатуры возрасты трёх человек (Антона, Бориса и Виктора) и определяет, кто из них старше.

Пример:

Возраст Антона: 15

Возраст Бориса: 17

Возраст Виктора: 16

Ответ: Борис старше всех.

Пример:

Возраст Антона: 17

Возраст Бориса: 17

Возраст Виктора: 16

Ответ: Антон и Борис старше Виктора.

На языке паскаль.

+3
Ответы (1)
  1. 3 февраля, 02:22
    0
    Program p1;

    var a, b:integer;

    begin

    writeln ('Введите 2 числа') ;

    readln (a, b) ;

    if a=b then writeln ('Числа одинаковые')

    else if a>b then

    begin writeln ('Наибольшее число ', a) ;

    writeln ('Наименьшее число ', b) ;

    end

    else begin writeln ('Наибольшее число ', b) ;

    writeln ('Наиментшее число 10 ', a) ;

    end;

    end.

    program p2;

    var a, b, c, d:integer;

    begin

    writeln ('Введите 4 числа') ;

    readln (a, b, c, d) ;

    if a
    if c
    if a
    writeln ('Наибольшее число ', a) ;

    end.

    program p3;

    var a, b, v:integer;

    begin

    writeln ('Введите возрасты людей:') ;

    write ('Антона - ') ;

    readln (a) ;

    write ('Бориса - ') ;

    readln (b) ;

    write ('Виктора - ') ;

    readln (v) ;

    if (a=b) and (a=v) then writeln ('Все люди одного возраста') ;

    if (a=b) and (a>v) then writeln ('Антон и Борис старше Виктора') ;

    if (a=b) and (a
    else if (v>a) and (v>b) then writeln ('Виктор старше всех') ;

    if (b=v) and (b>a) then writeln ('Борис и Виктор старше Антона') ;

    if (b=v) and (b
    else if (a>v) and (a>b) then writeln ('Антон старше всех') ;

    if (a=v) and (a>b) then writeln ('Антон и Виктор старше Бориса') ;

    if (a=v) and (a
    else if (b>v) and (b>a) then writeln ('Борис старше всех') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите: Практическая работа №3. Ветвления Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы