Задать вопрос
3 мая, 11:51

Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) подсчет суммы и среднего арифметического введённых положительных чисел и определение максимального (наибольшего) из введённых чисел. Используйте оператор repeat.

+1
Ответы (1)
  1. 3 мая, 15:24
    0
    Var

    a, i, max: integer;

    sum: real;

    begin

    max : = 0;

    sum : = 0;

    i : = 0;

    repeat

    write ('Введите число: ') ;

    readln (a) ;

    if a > 0

    then begin

    sum : = sum + a;

    i : = i + 1;

    end;

    if max < a

    then max : = a;

    until a = 0;

    writeln (#10,'Сумма = ', sum, #10, 'Среднее арифметическое = ', sum / i, #10, 'Наибольшее число - ', max) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) подсчет суммы и ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы