Задать вопрос
27 ноября, 05:48

Напишите программу, которая находит в массиве минимальный и максимальный из чётных положительных элементов.

Входные данные

Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива. Гарантируется, что 0 < N≤ 10000.

Выходные данные

Программа должна вывести в одной строке минимальный и максимальный из чётных положительных элементов массива, разделив их пробелом. Если в массиве нет чётных положительных элементов, программа должна вывести два числа - 1.

+4
Ответы (1)
  1. 27 ноября, 09:39
    0
    program HelloWorld;

    var a: array of integer;

    var N, min, max, i, variable:integer;

    begin

    min : = 32767;

    max : = 0;

    readln (N) ;

    for i : = 0 to N do begin

    readln (variable) ;

    if (variable > 0) and (variable mod 2 = 0) and (variable > max) then

    max : = variable;

    if (variable > 0) and (variable mod 2 = 0) and (variable < min) then

    min : = variable;

    end;

    if (max 0) and (min 32767) then

    writeln (min, ' ', max)

    else

    writeln (-1) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая находит в массиве минимальный и максимальный из чётных положительных элементов. Входные данные Первая строка ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы