Задать вопрос
24 мая, 09:24

Дано четырехзначное число. Изменить его так чтобы количество десятков стало равно нулю (написать программу паскаль)

+3
Ответы (2)
  1. 24 мая, 10:27
    0
    var a:integer;

    begin

    a:=1234;

    a: = (a div 100) * 100 + a mod 10;

    Write ('a = ', a) / / тут выведет: a = 1204

    end.
  2. 24 мая, 13:03
    0
    var a, b1, b2:integer;

    begin

    readln (a) ; / / считываем число

    b1:=a mod 10; / / единицы

    b2: = (a - b1) mod 100; / / десятки

    write (a-b2) ; / / число минус десятки

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано четырехзначное число. Изменить его так чтобы количество десятков стало равно нулю (написать программу паскаль) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы