Задать вопрос
16 января, 09:42

Ограничение времени 1 секунда

Ограничение памяти 64Mb

Ввод стандартный ввод или input. txt

Вывод стандартный вывод или output. txt

Формат ввода

В первой строке входного файла записано натуральное число N (3 ≤ N ≤ 1 000 000). Во второй строке записано N неотрицательных целых чисел через пробел, каждое из которых не превосходит 1 000 000 000.

Формат вывода

В выходной файл выведите три искомых числа. Если ответов несколько, выведите те числа, которые расположены левее. Если таких чисел нет, выведите - 1.

+1
Ответы (2)
  1. 16 января, 11:49
    0
    ar a:integer;

    begin

    read (a) ;

    if a div 2, then writeln ('YES')

    else writeln ('NO') ;

    end.
  2. 16 января, 13:03
    0
    var a:integer;

    begin

    read (a) ;

    if a div 2, then writeln ('YES')

    else writeln ('NO') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Ограничение времени 1 секунда Ограничение памяти 64Mb Ввод стандартный ввод или input. txt Вывод стандартный вывод или output. txt Формат ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы