Задать вопрос
10 августа, 12:24

Составьте программу заполнения массива из 100 чисел случайными значениями из диапазона от - 20 до 20. Подсчитайте в этом массиве количество положительных и количество отрицательных значений.

+3
Ответы (1)
  1. 10 августа, 13:07
    0
    Var a: array[0 ... 99] of Integer;

    i, pol, otr: Integer;

    begin

    for i:=0 to 99 do

    begin

    a[i]:=random (41) - 20;

    end;

    for i:=0 to 99 do

    begin

    if a[i]>0 then Inc (pol) ;

    if a[i]<0 then Inc (otr) ;

    end;

    writeln ('Положительных: ', pol) ;

    writeln ('Отрицательных: ', otr) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу заполнения массива из 100 чисел случайными значениями из диапазона от - 20 до 20. Подсчитайте в этом массиве количество ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы