Задать вопрос
11 апреля, 07:38

Написать код к заданию: Напишите программу, которая будет определять наибольшую цифру во введенном трехзначном числе.

+3
Ответы (1)
  1. 11 апреля, 10:18
    0
    Var

    a: integer;

    a1, a2, a3, max: byte;

    begin

    readln (a) ;

    a1 : = a div 100;

    a2 : = a mod 100 div 10;

    a3 : = a mod 10;

    max : = a1;

    if (a2 > max) then

    max : = a2;

    if (a3 > max) then

    max : = a3;

    writeln (max) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать код к заданию: Напишите программу, которая будет определять наибольшую цифру во введенном трехзначном числе. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы