Задать вопрос
9 августа, 09:36

Сколько существует трёхзначных чисел, в записи которых встречается только одна двойка? Составьте программу для получения правильного ответа.

+1
Ответы (1)
  1. 9 августа, 11:23
    0
    var a, b, c, k: integer;

    begin

    k:=0;

    for a:=1 to 9 do

    for b:=0 to 9 do

    for c:=0 to 9 do

    if (a=2) and (b2) and (c2) or

    (a2) and (b=2) and (c2) or

    (a2) and (b2) and (c=2) then k:=k+1;

    writeln ('k = ', k) ;

    end.

    Результат:

    k = 225
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Сколько существует трёхзначных чисел, в записи которых встречается только одна двойка? Составьте программу для получения правильного ответа. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Задание 1. составьте программу вычисления количества двузначных чисел, которые кратны 2 и 3. задание 2. составьте программу, выводящую на экран все двузначные числа, у которых первая цифра в два раза больше второй. задание 3.
Ответы (1)
1. составить программу вывода на экран всех трехзначных чисел, кратных 9. (паскаль, тремя способами) 2. Составить программу вычисления суммы всех трехзначных чисел, кратных 17. (паскаль, тремя способами)
Ответы (1)
1) Составьте программу вычисления сумму чисел от 1 до 100. 2) Составьте программу вычисления произведения чётных чисел от 1 до 10. 3) Составьте программу вычисления количества двухзначных нечётных чисел.
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Напишите программу по выдаче рандомных чисел, содержащих от 1 до 5 знаков, состоящих из чисел от 1 до 12, так чтобы: За цифрой 1 могли следовать только цифры 4, 5, 7, 9, 10 За цифрой 2 - только 5, 6, 8, 10, 11 За цифрой 3 - только 6, 7, 9, 11, 12 За
Ответы (1)