Задать вопрос
20 сентября, 03:48

Помогите написать программу (Паскаль), которая посчитает сумму пяти разных чисел, который может ввести пользователь самостоятельно. Написать программу для трех случаев, с циклом while, repeat и for

+1
Ответы (1)
  1. 20 сентября, 07:16
    0
    program a1;

    var

    i, n, s: integer;

    begin

    writeln ('Введите 5 чисел') ;

    for i:=1 to 5 do

    begin

    read (n) ;

    s+=n

    end;

    Writeln (s) ;

    writeln ('Введите 5 чисел') ;

    s:=0;

    i:=1;

    while i<=5 do

    begin

    read (n) ;

    s+=n;

    i+=1

    end;

    Writeln (s) ;

    writeln ('Введите 5 чисел') ;

    s:=0;

    i:=0;

    repeat

    i+=1;

    read (n) ;

    s+=n;

    until i=5;

    Writeln (s)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу (Паскаль), которая посчитает сумму пяти разных чисел, который может ввести пользователь самостоятельно. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы