Задать вопрос
18 ноября, 09:37

Сколько чисел от 1 до 100 включительно удовлетворяют такому условию:

(x div 10 = 0) or ((x div 10 mod 2 = 1) and (x > = 50)) ?

+1
Ответы (1)
  1. 18 ноября, 13:10
    0
    Данная программа выводит числа, которые являются однозначными или если число, находящееся разряде десятков нечетно, и больше либо равно 50.

    Ответ: 39.

    Программа на языке C++.

    #include

    using namespace std;

    int main () {

    int count;

    for (int x = 1; x < = 100; x++) {

    if ((x/10 = = 0) || (((x/10) %2 = = 1) && (x > = 50))) {

    ++count;

    cout << count << ". " << x << endl;

    }

    }

    }
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Сколько чисел от 1 до 100 включительно удовлетворяют такому условию: (x div 10 = 0) or ((x div 10 mod 2 = 1) and (x > = 50)) ? ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы