Задать вопрос
21 февраля, 07:22

Составьте программу, которая формирует массив из 15 случайных целых чисел от - 20 до 20 и четные числа делит на 2, а нечетные умножает на 3 PascalABC

+1
Ответы (1)
  1. 21 февраля, 10:57
    0
    Program n1;

    var a: array[1 ... 15] of integer;

    i: integer;

    begin

    write ('исходный массив: ') ;

    for i:=1 to 15 do begin

    a[i]:=random (41) - 20;

    write (a[i],' ') ;

    end;

    writeln;

    write ('полученный массив: ') ;

    for i:=1 to 15 do begin

    if a[i] mod 2=0 then a[i]:=trunc (a[i]/2) else a[i]:=a[i]*3;

    write (a[i],' ') ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу, которая формирует массив из 15 случайных целых чисел от - 20 до 20 и четные числа делит на 2, а нечетные умножает на 3 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы