Задать вопрос
13 апреля, 04:57

Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят!

Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15. Задача "B": Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. Пример: Введите натуральное число: 12342 Нет. Пример: Введите натуральное число: 12245 Да.

+3
Ответы (2)
  1. 13 апреля, 05:29
    0
    begin

    var s : = ReadString ('n = ') ;

    s. Aggregate (0, (Sum, x) - > Sum + x. toDigit). Println;

    var i : = 2;

    while (i < = s. Length) and (s[i] s[i - 1]) do i + = 1;

    Print (i > s. Length? 'No' : 'Yes')

    end.
  2. 13 апреля, 06:31
    0
    A)

    var num, sum, i, temp: Integer;

    begin

    print ('Number: ') ;

    readln (num) ;

    temp: = num;

    i:=1;

    while (temp 0) do

    begin

    temp: = temp div 10;

    if (temp = 0) then break;

    i: = i+1;

    end;

    temp: = i;

    sum:=0;

    for i:=0 to temp do

    begin

    sum: = sum + (num mod 10) ;

    num: = num div 10;

    end;

    println ('Sum: ', sum) ;

    end.

    B)

    var num, temp: Integer;

    bool:boolean;

    begin

    readln (num) ;

    temp : = num mod 10;

    num : = num div 10;

    while (num0) do

    begin

    if (temp = num mod 10)

    then

    begin

    bool:=true;

    break;

    end;

    temp : = num mod 10;

    num : = num div 10;

    end;

    if bool then write ('Yes') else write ('No') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Python. Уровень B. Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. Пример: Введите натуральное число: 12342 Нет. Пример: Введите натуральное число: 12245 Да.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
1) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. 2) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).
Ответы (1)
Помогите создвть программу в python. Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом). (p. s.
Ответы (1)
Ввести целое число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. Пример: Введите целое число: Введите целое число: 1232 1224 Нет. Да. Через ветвление, while, repeat, until
Ответы (1)