Задать вопрос
8 февраля, 06:46

Составьте программу паскаль для нахождения всех счастливых автобусных билетов чтобы из низ извлекался квадратный корень

+1
Ответы (1)
  1. 8 февраля, 08:04
    0
    Программа, которая сравнивает первые 3 со вторыми 3 мя ниже, но я не понял к чему было упоминание корня в первоначальном задании

    Program bilet;

    var

    a, b, c:longint;

    i:byte;

    begin

    writeln ('vvrdite nomer') ;

    readln (a) ;

    b:=0;

    c:=0;

    for i:=1 to 6 do

    if i<4 then begin

    b:=b + (a mod 10) ;

    a:=a div 10;

    end

    else begin

    c:=c + (a mod 10) ;

    a:=a div 10;

    end;

    if b=c then writeln ('schastlivuy ', c,' = ', b)

    else writeln ('uvyu ', c,' ', b) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу паскаль для нахождения всех счастливых автобусных билетов чтобы из низ извлекался квадратный корень ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы