Задать вопрос
12 сентября, 16:05

Помогите найти юному математику все трехзначные числа, в десятичной записи которых нет одинаковых цифр и вывести эти числа в возрастающем порядке. Составьте блок-схему алгоритма или опишите алгоритм на русском языке, или составьте программу на языке программирования

+5
Ответы (1)
  1. 12 сентября, 17:26
    0
    Программа на языке Паскаль:

    var

    n, a, b, c, t: integer;

    begin

    for n : = 100 to 999 do

    begin

    a : = n div 100;

    b : = (n div 10) mod 10;

    c : = n mod 10;

    if (a b) and (b c) and (c a) then Writeln (n) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите найти юному математику все трехзначные числа, в десятичной записи которых нет одинаковых цифр и вывести эти числа в возрастающем ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы