Задать вопрос
15 февраля, 23:14

Составить программу по условию: дан массив из 10 элементов. Найти сумму элементов, кратных 3 и двузначных. Массив задан случайно

на паскале

+1
Ответы (1)
  1. 16 февраля, 03:00
    0
    Так как задание не формализовано выводит последовательно суммы кратных 3 и двухзначных чисел

    Program TZ5;

    const

    n=10;

    var

    a:array [1 ... n] of integer;

    i, b:integer;

    begin

    randomize;

    for i:=1 to n do begin

    a[i]:=random (20) ;

    a[i]:=a[i]-10;

    writeln (i,' ', a[i]) ;

    end;

    b:=0;

    for i:=1 to n do

    if (a[i] mod 3) = 0 then

    b:=b+a[i];

    writeln ('summa kratnyh 3m=', b) ;

    b:=0;

    for i:=1 to n do

    if abs (a[i]) >9 then b:=b+a[i];

    writeln ('summa dvuhznachnyh = ', b) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу по условию: дан массив из 10 элементов. Найти сумму элементов, кратных 3 и двузначных. Массив задан случайно на паскале ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы